NetBSD 6.1 Release Candidate 1

February 22, 2013 posted by Jeff Rizzo

The first release candidate of NetBSD 6.1 is now available for download at:

NetBSD 6.1 will be the first feature update for the NetBSD 6 branch. There are many new drivers, some new features, and many bug fixes! Highlights include:

  • Bugfixes and feature improvements to NPF, the NetBSD Packet Filter
  • Improvements to several ARM platforms, including Raspberry Pi which now has nearly-complete support.
  • Support for dtrace on amd64
  • MIPS ports switched to gdb 7.3.1, gdb6 removed
  • Additional device support in key drivers including wm(4), uftdi(4), mfi(4), bge(4), aac(4), tlp(4) and others.
  • Various port-specific improvements to the amiga, arm, sparc64 and x68k ports.

A complete list of changes can be found at:

Please help us test this and any upcoming release candidates as much as possible. Remember, any feedback is good feedback. We'd love to hear from you, whether you've got a complaint or a compliment.




Ok, thanks a lot for your effort, i will test the RC1

Posted by Edgar Rodolfo on February 23, 2013 at 10:01 AM UTC #

Keep em comin:) Hope to one day see netbsd running on the sam460ex ppc boards. /M

Posted by Morpa on February 23, 2013 at 06:18 PM UTC #

With all the improvements for the Raspberry Pi, would it be possible to also distribute the kernel.img for Raspberry Pi (in addition to the netbsd format kernel)? I have so far been able to successfully update the userland on my Raspberry Pi to 6.1rc1, but can't find the kernel in the correct format (and am a bit reluctant to compile a kernel myself from the sources).

Posted by Christof Meerwald on February 24, 2013 at 06:40 PM UTC #

Not sure where to send testing results. When using NetBSD 6.1 RC1 i386 and npf I get an ioctl error when trying to start npf. In the npf.conf if I have: procedure "rid" { normalise: "random-id" } and then do: npfctl stop npfctl flush npfctl reload it gives an ioctl error. But if the normalise line is commented out, then it starts fine. This was not a problem in 6.0.1. Also I cannot load npf_ext_log at boot time using boot.cfg. I've tried multiple different ways and always fails to load, but once the server is up, it can be loaded manually with modload.

Posted by Gary on February 27, 2013 at 01:31 PM UTC #

Using normalisation in npf 6.1 RC1 was fixed by loading the module npf_ext_normalise.

Posted by Gary on February 28, 2013 at 03:29 AM UTC #

Where do I download a Raspberry Pi BSD image from please? Eager to get started!

Posted by Nick Pettefar on March 07, 2013 at 12:47 AM UTC #

Post a Comment:
Comments are closed for this entry.